Talk:Buckler buckle

From TheKolWiki
Jump to: navigation, search

It appears that the only shields affected by the May 13th 2009 update are the Spongy Shield and Eelskin Shield. Their new recipes require a Meat Shield instead of a Buckler Buckle. --Snufstyle420 23:57, 13 May 2009 (UTC)